FAQ

Here you can find answers to the most common questions about Cogmed.

What are the system requirements for Cogmed?

Cogmed can be used on the following platforms:

  • A browser with the latest version of Flash Player plugin installed. We recommend the latest version of Chrome, Safari or Edge. Login at mycogmed.com
  • iPad available on Apple App Store
  • Android available on Google Play Store (only older Android versions before 8 are currently supported). We recommend a device with 7" screen or larger.

The program requires a reliable and stable Internet connection.

Will Cogmed work after Flash is deprecated?

Yes, we will update our software to not rely on the Adobe Flash technology, which will be deprecated by the end of 2020.

Where can I get customer support?

  • For administrative questions (e.g. account and billing), please contact your Pearson representative
  • For tech support, please include your username and a detailed description of your issue to support@cogmed.com